Compatibility of our Products with WoltLab Suite™ 5.3

  • In the near future WoltLab Suite™ 5.3 will be released. As our products are basically compatible with WoltLab Suite™ 5.3, no adjustments will be necessary. However, if you have problems with one of our software products after updating to WoltLab Suite™ 5.3, please do not hesitate to contact us.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!